25th September 2019

my.hay02.gdaas.com HAY02 Desktops access failure

UPDATE: issue has been solved. For any related problems, please send an email and ask for support at: support@cloudalize.com

UPDATE: we have identified the problem and the responsible team is working to resolve it.

We are investigating an issue. Please keep checking https://status.cloudalize.com for updates.